Let's Share your experience!!!

Close (X)

Kisi-kisi Soal UTS dan UAS Elektronika Beserta Jawaban

SOAL A 1) Berikut ini yang termasuk komponen elektronika dengan jenis komponen pasif yaitu ....

Install Raspbian sampai koneksi dengan VNC Viewer disertai username dan password

Pernahkah kawan-kawan install raspbian di Raspberry Pi tanpa keyboard, mungkin akan sulit yah. namun hal ini bisa dilakukan dengan menggunakan proses remote dengan VNC Viewer yang telah tersedia di Raspbian yang tentunya telah di download dan ditanam dalam Raspberry.

Remove Bios Password and Harddissk (HDD) Laptop

I think to remove the bios password on an average PC is already can, although without having to memorize the password. the system jumpers or removing battery bios. ever see a supervisor, admin, system, HDD, bios, setup password?

Memperbaiki Kick Starter Motor Matic

Motor Matic is a motor that is the easiest to use and most in our homeland. please note that the motor also takes care of very sensitive, just like a computer that also takes care of sensitive anyway.

Gejala Kerusakan Mesin Air Submersible Metabo

Mesin Air Submersible atau yang sering disebut kebanyakan orang (satelit) ini sangat bagus, dengan sistemnya yang canggih dan fleksible. tipe mesin yang berbasis kerja di dalam tanah dan hanya menggunakan satu pipa ini, sangat berguna untuk anda yang memiliki banyak lumpur atau air kuning setelah pengeboran.

Wednesday, October 30, 2013

Cara Upload Drag and Drop File di Ubuntu


Terkadang kita bingung sob kalo ada di suatu web yang menyediakan drag and drop untuk mengupload file, Drag here, biasanya gitu, itu seakan ngeledek bagi saya, kenapa? karena susah bro di ubuntu di drag eh malah ga bisa, apa lagi salah satu web komunitas seperti koding.com hanya bisa mengupload via drag and drop file, nyelekit dah, Eittss tunggu dulu, bukan anak linux namanya kalo cuman hanya
Share:

Cara Upload Drag and Drop File di Ubuntu


Terkadang kita bingung sob kalo ada di suatu web yang menyediakan drag and drop untuk mengupload file, Drag here, biasanya gitu, itu seakan ngeledek bagi saya, kenapa? karena susah bro di ubuntu di drag eh malah ga bisa, apa lagi salah satu web komunitas seperti koding.com hanya bisa mengupload via drag and drop file, nyelekit dah, Eittss tunggu dulu, bukan anak linux namanya kalo cuman hanya
Share:

Monday, October 28, 2013

Cara Install BBM Android di Ubuntu


Oke sob masih dalam isu BBM yang kian memanas hehehee, saatnya memposting Cara install BBM di Ubuntu nih sob, kali aja ada yang mampir kesini, senernya caranya sama ga ada bedanya dengan cara install dengan windows, bedanya di linux lebih cepet jalannya dan masalah yang timbul itu minim itu aja yang saya rasakan hehehehe, langsung saja sob, persiapkan alat-alat ini



Download



1. VirtualBox 
Share:

Cara Install BBM Android di Ubuntu


Oke sob masih dalam isu BBM yang kian memanas hehehee, saatnya memposting Cara install BBM di Ubuntu nih sob, kali aja ada yang mampir kesini, senernya caranya sama ga ada bedanya dengan cara install dengan windows, bedanya di linux lebih cepet jalannya dan masalah yang timbul itu minim itu aja yang saya rasakan hehehehe, langsung saja sob, persiapkan alat-alat ini



Download



1. VirtualBox 
Share:

Friday, October 25, 2013

How To: Install Aplikasi BlackBerry Messenger for Android di Ubuntu mu


Well, beberapa hari yang lalu (sampai tulisan ini ditulis) aplikasi BlackBerry Messenger (BBM) Cross Platform menjadi booming di kalangan pengguna Sistem Operasi Mobile. BBM yang dulu hanya eksklusif di perangkat BlackBerry, kini hadir di perangkat android dan iOS. Sebagian besar pengguna android sangat antusias dalam mencoba untuk memasang aplikasi BBM ini.

Namun sayang beberapa mengalami kendala, salah satunya adalah pengguna android yang masih memakai versi gingerbread dan yang masih menggunakan arsitektur ARMv6. Syarat tertulis untuk menginstall BBM di Google's Playstore adalah minimal menggunakan versi android ICS (4.0.x), sedangkan "syarat tak tertulisnya" adalah penggunaan arsitektur CPU minimal ARMv7 (di dalam file apk BBM, setelah saya lihat, ada code armeabi-v7). Lalu bagaimana dengan nasib ratusan ribu, bahkan jutaan user android yang device nya masih memakai arsitektur ARMv6? tenang saja, masih banyak jalan menuju Roma. 

Kamu dapat menggunakan aplikasi BBM lewat PC/Laptop, khusus pada tulisan ini saya akan menjelaskan tutorial penggunaanya di Linux (terutama Ubuntu). Untuk distro Linux yang lainnya, hampir sama step by step dan apa saja yang dibutuhkan. Kita akan menggunakan Android SDK (Software Development Kit) yang didalamnya terdapat tools penting untuk memakai aplikasi BBM ini, yaitu Android Virtual Device (AVD). Meskipun ada cara lain yang dapat dipergunakan untuk "bermain BBM" di PC/Laptop, akan tetapi cara ini merupakan cara (emulator) yang paling manjur untuk digunakan di hampir semua PC/Laptop.
Untuk hanya sekedar menggunakan AVD, kita tidak perlu mendownload full SDK dan tools, kita cukup menggunakan beberapa saja. Berikut adalah step by step tutorial nya :
1. Install JDK (java develompent kit), kita akan menggunakan openJDK.
Buka terminal, copy-paste kan  perintah berikut :
sudo apt-get install openjdk-6-jre openjdk-6-jdk icedtea6-plugin

2. Jika kamu memakai sistem operasi 64-bit, perlu untuk menginstall library 32-bit
sudo apt-get install ia32-libs

3. Download dan install Android SDK, sesuaikan dengan sistem operasi nya.
Download disini, cukup download SDK Tools Only.

4. Buat folder untuk android SDK nya dan untar file hasil download tadi, contoh :
mkdir ~/development
cd ~/Downloads
tar -zxvf android-sdk_r22.1.1-linux.tgz
mv ~/Downloads/android-sdk-linux ~/development/

5. Setup ADB/Fastboot
cd ~/development/android-sdk-linux/tools
./android

yang perlu kamu install adalah Extras, Android SDK Tools, Android SDK Platform-Tools, Android SDK Build-tools, dan Virtual Device image, dalam hal ini saya menginstall versi Android 4.3 (API 18) perlu diingat bahwa untuk menjalankan aplikasi BBM diperlukan API 15 (Android 4.0.3). file yang perlu untuk diinstall adalah SDK Platform, Samples for SDK, ARM EABI v7a System Image, dan Google APIs. cukup itu saja.

Klik untuk memperbesar gambar
setelah selesai, buka jendela terminal baru ketikkan:
sudo gedit .bashrc
masukkan tulisan ini di akhir halaman 
#Android PATHS
export PATH=$PATH:~/development/android-sdk-linux/tools
export PATH=$PATH:~/development/android-sdk-linux/platform-tools
Setelah step diatas selesai, buka tools di toolbar android SDK, klik AVD, buat baru (new) setting seadanya dan klik start.

Klik untuk memperbesar gambar
6. Download disini untuk file APK BBM.
copy-pastekan di folder home/development/android-sdk-linux/platform-tools
buka terminal di lokasi folder tersebut, ketik :
./adb install BBM_1_0_0_72.apk
tunggu sampai proses instalasi selesai, lalu pindah ke jendela AVD.

Proses start up AVD memang cukup lama, terutama bagi PC/Laptop yang hardware nya mepet (khusus untuk yang hardware nya mepet, pakai android API yang ter rendah yaitu 15, karena semakin rendah semakin ringan), ditunggu saja sekitar 5-15 menit. Setelah itu klik icon BBM, maka akan memasuki halaman untuk antrian email (EDIT. info terbaru bahwa BlackBerry Ltd. sudah meniadakan antrian email). Setelah tembus, segera buat Blackberry ID apabila kamu belum mempunyai BB ID, atau sign in apabila kamu sudah mempunyai sebelumnya. Kemudian kamu akan mendapat PIN BBM yang dapat kamu pergunakan.




EDIT (01/11/13) : jika ingin menginstall multiple aplikasi BBM / Multi PIN di 1 device/ emulator, dapat download APK yang telah saya upload disini (support max. 5 BB ID/PIN, lebih dari itu akan terasa berat untuk di running) dan APK tersebut support landscape mode. Ketika tulisan ini ditulis, aplikasi BBM resmi hanya bisa portrait mode :D

Selamat kamu sudah dapat menggunakan BlackBerry Messenger di Linux (ubuntu) Machine kamu.
RUMIT??? yang kita butuhkan adalah PROSES, bukannya HASIL AKHIR semata. Itulah yang membedakan UNIX/Linux dengan sistem operasi lainnya. :)

Semoga Bermanfaat.
Share:

How To: Install Aplikasi BlackBerry Messenger for Android di Ubuntu mu


Well, beberapa hari yang lalu (sampai tulisan ini ditulis) aplikasi BlackBerry Messenger (BBM) Cross Platform menjadi booming di kalangan pengguna Sistem Operasi Mobile. BBM yang dulu hanya eksklusif di perangkat BlackBerry, kini hadir di perangkat android dan iOS. Sebagian besar pengguna android sangat antusias dalam mencoba untuk memasang aplikasi BBM ini.

Namun sayang beberapa mengalami kendala, salah satunya adalah pengguna android yang masih memakai versi gingerbread dan yang masih menggunakan arsitektur ARMv6. Syarat tertulis untuk menginstall BBM di Google's Playstore adalah minimal menggunakan versi android ICS (4.0.x), sedangkan "syarat tak tertulisnya" adalah penggunaan arsitektur CPU minimal ARMv7 (di dalam file apk BBM, setelah saya lihat, ada code armeabi-v7). Lalu bagaimana dengan nasib ratusan ribu, bahkan jutaan user android yang device nya masih memakai arsitektur ARMv6? tenang saja, masih banyak jalan menuju Roma. 

Kamu dapat menggunakan aplikasi BBM lewat PC/Laptop, khusus pada tulisan ini saya akan menjelaskan tutorial penggunaanya di Linux (terutama Ubuntu). Untuk distro Linux yang lainnya, hampir sama step by step dan apa saja yang dibutuhkan. Kita akan menggunakan Android SDK (Software Development Kit) yang didalamnya terdapat tools penting untuk memakai aplikasi BBM ini, yaitu Android Virtual Device (AVD). Meskipun ada cara lain yang dapat dipergunakan untuk "bermain BBM" di PC/Laptop, akan tetapi cara ini merupakan cara (emulator) yang paling manjur untuk digunakan di hampir semua PC/Laptop.
Untuk hanya sekedar menggunakan AVD, kita tidak perlu mendownload full SDK dan tools, kita cukup menggunakan beberapa saja. Berikut adalah step by step tutorial nya :
1. Install JDK (java develompent kit), kita akan menggunakan openJDK.
Buka terminal, copy-paste kan  perintah berikut :
sudo apt-get install openjdk-6-jre openjdk-6-jdk icedtea6-plugin

2. Jika kamu memakai sistem operasi 64-bit, perlu untuk menginstall library 32-bit
sudo apt-get install ia32-libs

3. Download dan install Android SDK, sesuaikan dengan sistem operasi nya.
Download disini, cukup download SDK Tools Only.

4. Buat folder untuk android SDK nya dan untar file hasil download tadi, contoh :
mkdir ~/development
cd ~/Downloads
tar -zxvf android-sdk_r22.1.1-linux.tgz
mv ~/Downloads/android-sdk-linux ~/development/

5. Setup ADB/Fastboot
cd ~/development/android-sdk-linux/tools
./android

yang perlu kamu install adalah Extras, Android SDK Tools, Android SDK Platform-Tools, Android SDK Build-tools, dan Virtual Device image, dalam hal ini saya menginstall versi Android 4.3 (API 18) perlu diingat bahwa untuk menjalankan aplikasi BBM diperlukan API 15 (Android 4.0.3). file yang perlu untuk diinstall adalah SDK Platform, Samples for SDK, ARM EABI v7a System Image, dan Google APIs. cukup itu saja.

Klik untuk memperbesar gambar
setelah selesai, buka jendela terminal baru ketikkan:
sudo gedit .bashrc
masukkan tulisan ini di akhir halaman 
#Android PATHS
export PATH=$PATH:~/development/android-sdk-linux/tools
export PATH=$PATH:~/development/android-sdk-linux/platform-tools
Setelah step diatas selesai, buka tools di toolbar android SDK, klik AVD, buat baru (new) setting seadanya dan klik start.

Klik untuk memperbesar gambar
6. Download disini untuk file APK BBM.
copy-pastekan di folder home/development/android-sdk-linux/platform-tools
buka terminal di lokasi folder tersebut, ketik :
./adb install BBM_1_0_0_72.apk
tunggu sampai proses instalasi selesai, lalu pindah ke jendela AVD.

Proses start up AVD memang cukup lama, terutama bagi PC/Laptop yang hardware nya mepet (khusus untuk yang hardware nya mepet, pakai android API yang ter rendah yaitu 15, karena semakin rendah semakin ringan), ditunggu saja sekitar 5-15 menit. Setelah itu klik icon BBM, maka akan memasuki halaman untuk antrian email (EDIT. info terbaru bahwa BlackBerry Ltd. sudah meniadakan antrian email). Setelah tembus, segera buat Blackberry ID apabila kamu belum mempunyai BB ID, atau sign in apabila kamu sudah mempunyai sebelumnya. Kemudian kamu akan mendapat PIN BBM yang dapat kamu pergunakan.




EDIT (01/11/13) : jika ingin menginstall multiple aplikasi BBM / Multi PIN di 1 device/ emulator, dapat download APK yang telah saya upload disini (support max. 5 BB ID/PIN, lebih dari itu akan terasa berat untuk di running) dan APK tersebut support landscape mode. Ketika tulisan ini ditulis, aplikasi BBM resmi hanya bisa portrait mode :D

Selamat kamu sudah dapat menggunakan BlackBerry Messenger di Linux (ubuntu) Machine kamu.
RUMIT??? yang kita butuhkan adalah PROSES, bukannya HASIL AKHIR semata. Itulah yang membedakan UNIX/Linux dengan sistem operasi lainnya. :)

Semoga Bermanfaat.
Share:

Thursday, October 24, 2013

Install Android Di Komputer Dengan Virtualbox


Helo ketemu lagi :) jangan bosen ya.. plis.

Selamat pagi semua, saya suka mngucapkan selamat pagi kapanpun itu karena, pagi itu bisa memberi kita banyak inspirasi dan awal dimana kita memupuk semangat untuk beraktivitas hingga akhirnya kita memejamkan mata saat malam tiba.

Wah.. jadi berorasi. Ceritanya saya baru saja menginstall aplikasi android yang familiar, Whatsapp di komputer dengan ubuntu 13.10. Sebagai frontend-nya saya menggunakan Virtualbox.

Screnshot di Android - Virtualbox, Ngobrol sendiri dengan nomor yg lain :)
Kebetulan sudah cukup lama saya memiliki file .iso android 4.1 yang berhasil saya instalkan di Virtualbox pada Ubuntu 13.10 (setelah diupgrade). Karena Whatsapp tersebut adalah yang saya dapatkan dari google play.

Screnshot di Lenovo P770i
Step installasi Whatsapp di Android - Virtualbox

  1. Pastikan kita telah mengaktivkan akun google
  2. Menuju Google Play di Android
  3. Cari Whatsapp dan install
  4. Daftarkan nomor kita
  5. Masukkan kode verifikasi yang dikirimkan whatssapp ke nomor kita
  6. Bisa juga kita mendapatkan kode tersebut dengan memilih tap to call
  7. Setelah selesai, tambahkan kontak & Whatsapp telah siap digunakan

Nah begitulah, simple dan tidak ribet. Mungkin yang agak ribet adalah saat kita mencoba untuk mendapat kode verifikasi yang dikirim ke handset kita.

Tapi selama kita mau berusaha, disitu akan ada jalan. cie.. cie.. cie.. :)


Share:

Install Android Di Komputer Dengan Virtualbox


Helo ketemu lagi :) jangan bosen ya.. plis.

Selamat pagi semua, saya suka mngucapkan selamat pagi kapanpun itu karena, pagi itu bisa memberi kita banyak inspirasi dan awal dimana kita memupuk semangat untuk beraktivitas hingga akhirnya kita memejamkan mata saat malam tiba.

Wah.. jadi berorasi. Ceritanya saya baru saja menginstall aplikasi android yang familiar, Whatsapp di komputer dengan ubuntu 13.10. Sebagai frontend-nya saya menggunakan Virtualbox.

Screnshot di Android - Virtualbox, Ngobrol sendiri dengan nomor yg lain :)
Kebetulan sudah cukup lama saya memiliki file .iso android 4.1 yang berhasil saya instalkan di Virtualbox pada Ubuntu 13.10 (setelah diupgrade). Karena Whatsapp tersebut adalah yang saya dapatkan dari google play.

Screnshot di Lenovo P770i
Step installasi Whatsapp di Android - Virtualbox

  1. Pastikan kita telah mengaktivkan akun google
  2. Menuju Google Play di Android
  3. Cari Whatsapp dan install
  4. Daftarkan nomor kita
  5. Masukkan kode verifikasi yang dikirimkan whatssapp ke nomor kita
  6. Bisa juga kita mendapatkan kode tersebut dengan memilih tap to call
  7. Setelah selesai, tambahkan kontak & Whatsapp telah siap digunakan

Nah begitulah, simple dan tidak ribet. Mungkin yang agak ribet adalah saat kita mencoba untuk mendapat kode verifikasi yang dikirim ke handset kita.

Tapi selama kita mau berusaha, disitu akan ada jalan. cie.. cie.. cie.. :)


Share:

Wednesday, October 23, 2013

Seting VLC Dengan Skin Non Standar

VLC Skin
Apabila kita merasa bosan dengan tampilan VLC media player, sebaiknya kita berfikir untuk menggunakan skin non standar.

Sebenarnya, seperti halnya winamp di windows dan beberapa media player juga mendukung penggunaan skin, maka sebenarnya VLC juga bisa menggunakan skin yang bukan standar.

Caranya untuk menggunakan skin di VLC
  • Pertama-tama kita bisa mendownload skin di sini
  • Buka VLC dan pilih Preference > Use custom skin
  • Extract skin yang tadi kita download dan simpan ke folder /usr/share/vlc/skins2
Untuk mengganti skin, pilihlah menu Interface > Choose Skin

Yap, segitu saja, selanjutnya silahkan untuk mencoba :)

Baca juga : Tips Mengatasi Error VLC
Share:

Seting VLC Dengan Skin Non Standar

VLC Skin
Apabila kita merasa bosan dengan tampilan VLC media player, sebaiknya kita berfikir untuk menggunakan skin non standar.

Sebenarnya, seperti halnya winamp di windows dan beberapa media player juga mendukung penggunaan skin, maka sebenarnya VLC juga bisa menggunakan skin yang bukan standar.

Caranya untuk menggunakan skin di VLC
  • Pertama-tama kita bisa mendownload skin di sini
  • Buka VLC dan pilih Preference > Use custom skin
  • Extract skin yang tadi kita download dan simpan ke folder /usr/share/vlc/skins2
Untuk mengganti skin, pilihlah menu Interface > Choose Skin

Yap, segitu saja, selanjutnya silahkan untuk mencoba :)

Baca juga : Tips Mengatasi Error VLC
Share:

VLC Error : "skins2 interface error: no skins found : exiting"

Vlc adalah salah satu media player terbaik. Saya juga menginstallnya di ubuntu dengan

sudo apt-get install vlc

Vlc ini mampu untuk memainkan berbagai format media yang ada, sehingga menjadikannya sebagai media player yang powerfull.

Vlc tersedia bebas untuk berbagai platform termasuk windows, linux, mac OS X dan bisa memainkan berbagai format media seperti :
  • MPEG-2
  • DivX
  • H.264
  • MKV
  • WebM
  • WMV
  • MP3
Apabila kita mengalami error  "skins2 interface error: no skins found : exiting" dimana tidak ditemukan skin yang ada dalam konfigurasinya.

Untuk mengatasi masalah tersebut, kita bisa  mengatasinya  dengan menghapus folder vlc yang ada di /home/user/.config/vlc

Kita bisa menghapus folder vlc tersebut, karena nantinya setelah folder itu dihapus dan kita kembali menjalankan vlc, maka secara otomatis vlc akan membuat konfigurasi ulang ditempat yang sama dengan setingan yang standar.

Demikianlah, cara yang saya gunakan ketika vlc mengalami error "skins2 interface error: no skins found : exiting".

Untuk uji coba, bisa juga kita me-rename folder /home/user/.config/vlc menjadi /home/user/.config/folder-lain, maka ketika vlc dijalankan, akan secara otomatis kembali membuat konfigurasi seperti yang tadi disebutkan.


Nah, gimana? Berani bereksperimen? :)
Share:

VLC Error : "skins2 interface error: no skins found : exiting"

Vlc adalah salah satu media player terbaik. Saya juga menginstallnya di ubuntu dengan

sudo apt-get install vlc

Vlc ini mampu untuk memainkan berbagai format media yang ada, sehingga menjadikannya sebagai media player yang powerfull.

Vlc tersedia bebas untuk berbagai platform termasuk windows, linux, mac OS X dan bisa memainkan berbagai format media seperti :
  • MPEG-2
  • DivX
  • H.264
  • MKV
  • WebM
  • WMV
  • MP3
Apabila kita mengalami error  "skins2 interface error: no skins found : exiting" dimana tidak ditemukan skin yang ada dalam konfigurasinya.

Untuk mengatasi masalah tersebut, kita bisa  mengatasinya  dengan menghapus folder vlc yang ada di /home/user/.config/vlc

Kita bisa menghapus folder vlc tersebut, karena nantinya setelah folder itu dihapus dan kita kembali menjalankan vlc, maka secara otomatis vlc akan membuat konfigurasi ulang ditempat yang sama dengan setingan yang standar.

Demikianlah, cara yang saya gunakan ketika vlc mengalami error "skins2 interface error: no skins found : exiting".

Untuk uji coba, bisa juga kita me-rename folder /home/user/.config/vlc menjadi /home/user/.config/folder-lain, maka ketika vlc dijalankan, akan secara otomatis kembali membuat konfigurasi seperti yang tadi disebutkan.


Nah, gimana? Berani bereksperimen? :)
Share:

Mempercantik Tampilan Desktop

Salah satu cara bagi kita untuk bisa mempercantik tampilan desktop adalah dengan menginstall conky.

Conky adalah semacam tool atau program untuk linux, BSD, Free BSD yang bisa menampilan  informasi :
  • CPU
  • Suhu
  • Hardisk
  • Jam dan tanggal
  • File Sistem
  • dll

Sehingga dengan menggunakan conky kita bisa memonitor sistem yang sedang berjalan.

Karena conky memiliki banyak theme dan juga tampilan yang menarik, sehingga banyak orang yang tertarik untuk menginstallnya di komputer mereka. Termasuk saya :)

Installasi

Lalu bagaimana cara kita untuk enginstall conky? Pastikan kita memiliki koneksi internet yang lancar.  Pastikan sebelum kita menginstall conky, terlebih dahulu untuk menginstall LM-Sensores :

sudo apt-get install lm-sensors

Setelah itu jalankan dengan pengaturan dengan

sudo sensors-detect

Setelah berhasil terinstall, langkah selanjutnya adalah dengan menginstall conky di terminal :
  1.  sudo apt-get install conky-all
  2.  Download Conky Loa disini
  3.  Extraklah file hasil download tadi, kemudian caril & extrakah  dari hasil extract tadi Conky ubuntu-loa.tar.gz


Masuk ke folder hasil extract dan rename conkyec menjadi .conkyrc (hiden, untuk melihatnya, dari nautilus tekan Ctrl + H)

  1. Copy .conkyrc ke folder home
  2. Buat folder .conky lalu copy fila lainnya (clock_rings.lua dan new-ubuntu-logo.png) ke folder .conky tersebut

Edit file .conkyrc di home dan replace :

/~.lua/scripts/clock_rings.lua
 menjadi
 ~/.conky/clock_rings.lua

Conky Manager
Untuk menjalankan, dari terminal ketikkan conky

Supaya kita mudah dalam melakukan pengaturan, sebaiknya install juga conky-manager, dengan cara :

sudo apt-add-repository ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install conky-manager


Setelah kita selesai, maka bisa melakukan pengaturannya dengan menggunakan perintah conky-manager dari terminal ataupun menggunakan keyword conky manager dari dash ubuntu.







Share:

Mempercantik Tampilan Desktop

Salah satu cara bagi kita untuk bisa mempercantik tampilan desktop adalah dengan menginstall conky.

Conky adalah semacam tool atau program untuk linux, BSD, Free BSD yang bisa menampilan  informasi :
  • CPU
  • Suhu
  • Hardisk
  • Jam dan tanggal
  • File Sistem
  • dll

Sehingga dengan menggunakan conky kita bisa memonitor sistem yang sedang berjalan.

Karena conky memiliki banyak theme dan juga tampilan yang menarik, sehingga banyak orang yang tertarik untuk menginstallnya di komputer mereka. Termasuk saya :)

Installasi

Lalu bagaimana cara kita untuk enginstall conky? Pastikan kita memiliki koneksi internet yang lancar.  Pastikan sebelum kita menginstall conky, terlebih dahulu untuk menginstall LM-Sensores :

sudo apt-get install lm-sensors

Setelah itu jalankan dengan pengaturan dengan

sudo sensors-detect

Setelah berhasil terinstall, langkah selanjutnya adalah dengan menginstall conky di terminal :
  1.  sudo apt-get install conky-all
  2.  Download Conky Loa disini
  3.  Extraklah file hasil download tadi, kemudian caril & extrakah  dari hasil extract tadi Conky ubuntu-loa.tar.gz


Masuk ke folder hasil extract dan rename conkyec menjadi .conkyrc (hiden, untuk melihatnya, dari nautilus tekan Ctrl + H)

  1. Copy .conkyrc ke folder home
  2. Buat folder .conky lalu copy fila lainnya (clock_rings.lua dan new-ubuntu-logo.png) ke folder .conky tersebut

Edit file .conkyrc di home dan replace :

/~.lua/scripts/clock_rings.lua
 menjadi
 ~/.conky/clock_rings.lua

Conky Manager
Untuk menjalankan, dari terminal ketikkan conky

Supaya kita mudah dalam melakukan pengaturan, sebaiknya install juga conky-manager, dengan cara :

sudo apt-add-repository ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install conky-manager


Setelah kita selesai, maka bisa melakukan pengaturannya dengan menggunakan perintah conky-manager dari terminal ataupun menggunakan keyword conky manager dari dash ubuntu.







Share:

Tuesday, October 22, 2013

Cara Install Adobe Air di Ubuntu


Pagi, siang, sore, malam sob. Oke buat para pengguna ubuntu ada dua kabar yang akan saya sampaikan, yang pertama kabar buruk, yaitu adobe air sudah tidak lagi mendukung atau mensuport linux, yang kedua kabar baiknya ada cara lain untuk menginsall adobe air di linux, ehehe istilahnya banyak jalan menuju pelaminan *eh, oke sob kita langsung saja.



NB : Saya pake 13.04







Untuk 32-Bit

Share:

Cara Install Adobe Air di Ubuntu


Pagi, siang, sore, malam sob. Oke buat para pengguna ubuntu ada dua kabar yang akan saya sampaikan, yang pertama kabar buruk, yaitu adobe air sudah tidak lagi mendukung atau mensuport linux, yang kedua kabar baiknya ada cara lain untuk menginsall adobe air di linux, ehehe istilahnya banyak jalan menuju pelaminan *eh, oke sob kita langsung saja.



NB : Saya pake 13.04







Untuk 32-Bit

Share:

Friday, October 18, 2013

Tutorial Installasi Ubuntu Server Di Virtual Box / VM Ware

Bonjour! Kita ketemu lagi di blog Tutorial Linux Ubuntu Berbahasa Indonesia. Kalau diingat-ingat di blog ini saya sudah cukup banyak memberikan tutorial-tutorial seputar linux khususnya ubuntu. Tapi, rasanya ada yang kurang :D

Rasanya saya melewatkan hal paling mendasar dalam menguasai linux ubuntu, jika tanpa memberikan tutorial installasi ubuntu server. Pada artikel ini saya menyajikan tutorial yang berbeda, proses installasi linux ubuntu server  ini akan saya lakukan di virtual box. Jika anda kebetulan sedang mencari panduan installasi linux ubuntu anda tidak salah tempat berkunjung. Saya sengaja tidak memasukkan video kedalam blog ini dikarenakan beberapa alasan. Untuk lebih jelasnya silahkan kunjungi video ini di youtube.

Tutorial Installasi Linux Ubuntu Server Di VirtualBox



Semoga bermanfaat,
Salam penguin! :)
Share:

Tutorial Installasi Ubuntu Server Di Virtual Box / VM Ware

Bonjour! Kita ketemu lagi di blog Tutorial Linux Ubuntu Berbahasa Indonesia. Kalau diingat-ingat di blog ini saya sudah cukup banyak memberikan tutorial-tutorial seputar linux khususnya ubuntu. Tapi, rasanya ada yang kurang :D

Rasanya saya melewatkan hal paling mendasar dalam menguasai linux ubuntu, jika tanpa memberikan tutorial installasi ubuntu server. Pada artikel ini saya menyajikan tutorial yang berbeda, proses installasi linux ubuntu server  ini akan saya lakukan di virtual box. Jika anda kebetulan sedang mencari panduan installasi linux ubuntu anda tidak salah tempat berkunjung. Saya sengaja tidak memasukkan video kedalam blog ini dikarenakan beberapa alasan. Untuk lebih jelasnya silahkan kunjungi video ini di youtube.

Tutorial Installasi Linux Ubuntu Server Di VirtualBox



Semoga bermanfaat,
Salam penguin! :)
Share:

Thursday, October 17, 2013

Upgrade Online Ubuntu 13.04 ke 13.10

Selain melakukan installasi/upgrade melalui cd/dvd installer yang telah kita download, kita juga bisa melakukan upgrade ubuntu 13.04 ke 13.10 secara online.

Apabila kita ingin melakukan upgrade secara online, pastikan bahwa kita memiliki koneksi internet yang cepat dan stabil, karena upgrade secara online bisa memakan waktu yang lebih lama dibanding kita melakukan upgrade secara offline. Berikut cara untuk melakukan upgrade secara online :

1. Jalankan update manager dari dash ubuntu
 

2. Check for updates, click pada check button untuk mengetahui adanya update terbaru, jika ditemukan click check sekali lagi setelah update komplet kemudian klik  Upgrade button untuk menginstall Ubuntu 13.10 secara online


3. Install/Upgrade, akan ada window Welcome to Ubuntu 13.10 'Saucy Salamander' klik Upgrade untuk memulai.


Tunggu sampai proses upgrading selesai, lamanya tergantung koneksi internet yang kita miliki.
Share:

Upgrade Online Ubuntu 13.04 ke 13.10

Selain melakukan installasi/upgrade melalui cd/dvd installer yang telah kita download, kita juga bisa melakukan upgrade ubuntu 13.04 ke 13.10 secara online.

Apabila kita ingin melakukan upgrade secara online, pastikan bahwa kita memiliki koneksi internet yang cepat dan stabil, karena upgrade secara online bisa memakan waktu yang lebih lama dibanding kita melakukan upgrade secara offline. Berikut cara untuk melakukan upgrade secara online :

1. Jalankan update manager dari dash ubuntu
 

2. Check for updates, click pada check button untuk mengetahui adanya update terbaru, jika ditemukan click check sekali lagi setelah update komplet kemudian klik  Upgrade button untuk menginstall Ubuntu 13.10 secara online


3. Install/Upgrade, akan ada window Welcome to Ubuntu 13.10 'Saucy Salamander' klik Upgrade untuk memulai.


Tunggu sampai proses upgrading selesai, lamanya tergantung koneksi internet yang kita miliki.
Share:

Memanggil The Matrix Ke Terminal Linux


Hey guys :) wow

Saya lagi ingat film The Matrix yang ada Keanu Reave-nya itu tuh... Ngomong-ngomong tentang The Matrix, di linux juga ada screensaver bertema The Matrix dengan deretan teks yang meluncur dari atas kebawah layar.

Meskipun sederhana, tapi menurutku itu keren. Keren banget.

Nang karena itu keren, makanya yuk kita coba panggil The Matrix ke terminal kita.

Caranya?

1. Install cmatrix dengan sudo apt-get install cmatrix
2. Panggil The Matrix dengan cmatrix

Nah begitulah guys. Simple kan? Ternyata linux memiliki perintah/program yang iseng tapi keren juga.

Selamat menikmati The Matrix. Wah Linux gak bikin linu juga rupanya.
Share:

Memanggil The Matrix Ke Terminal Linux


Hey guys :) wow

Saya lagi ingat film The Matrix yang ada Keanu Reave-nya itu tuh... Ngomong-ngomong tentang The Matrix, di linux juga ada screensaver bertema The Matrix dengan deretan teks yang meluncur dari atas kebawah layar.

Meskipun sederhana, tapi menurutku itu keren. Keren banget.

Nang karena itu keren, makanya yuk kita coba panggil The Matrix ke terminal kita.

Caranya?

1. Install cmatrix dengan sudo apt-get install cmatrix
2. Panggil The Matrix dengan cmatrix

Nah begitulah guys. Simple kan? Ternyata linux memiliki perintah/program yang iseng tapi keren juga.

Selamat menikmati The Matrix. Wah Linux gak bikin linu juga rupanya.
Share:

Ubuntu 13.10 Bisa di Download


Untuk pengguna Ubuntu, saat ini telah bisa mendownload versi terbaru dari sistem operasi berbasis linux yang paling populer ini.

Yap, Ubuntu 13.10 Saucy Salamander, bisa kamu download langsung dari situs resmi ubuntu. Langsung aja klik Get Ubuntu 13.10 now!

Dengan mengusung tagline Smarter and faster, ubuntu 13.10 ini memiliki beberapa varian untuk desktop, server, smartphone dan juga cloud computing.

Gimana? Penasaran dengan Ubuntu 13.10 terbaru? Gak usah banyak mikir dah, download dan coba rasakan :)
Share:

Ubuntu 13.10 Bisa di Download


Untuk pengguna Ubuntu, saat ini telah bisa mendownload versi terbaru dari sistem operasi berbasis linux yang paling populer ini.

Yap, Ubuntu 13.10 Saucy Salamander, bisa kamu download langsung dari situs resmi ubuntu. Langsung aja klik Get Ubuntu 13.10 now!

Dengan mengusung tagline Smarter and faster, ubuntu 13.10 ini memiliki beberapa varian untuk desktop, server, smartphone dan juga cloud computing.

Gimana? Penasaran dengan Ubuntu 13.10 terbaru? Gak usah banyak mikir dah, download dan coba rasakan :)
Share:

Monday, October 14, 2013

Cara Setting Load Balancing Mikrotik Metode PPC

Load Balance / Load Balancing Mikrotik adalah sebuah teknik atau metode untuk membagi beban ke dalam beberapa jalur (link) sehingga penggunaan jalur (link) menjadi lebih baik. Load balance Mikrotik Sebelumnya sudah pernah saya bahas pada artikel ini Load Balance / Load Balancing Mikrotik.


Selanjutnya pada artikel ini akan saya bahas tentang cara setting load balance mikrotik meggunakan metode PPC. Karena keterbatasan waktu dan peralatan, Tutorial Load Balance Mikrotik kali ini saya ambil dari web mikrotik.co.id sebagai berikut :

Selama ini banyak dari kita yang beranggapan salah, bahwa dengan menggunakan loadbalance dua jalur koneksi , maka besar bandwidth yang akan kita dapatkan menjadi dua kali lipat dari bandwidth sebelum menggunakan loadbalance (akumulasi dari kedua bandwidth tersebut). Hal ini perlu kita perjelas dahulu, bahwa loadbalance tidak akan menambah besar bandwidth yang kita peroleh, tetapi hanya bertugas untuk membagi trafik dari kedua bandwidth tersebut agar dapat terpakai secara seimbang.

Dengan artikel ini, kita akan membuktikan bahwa dalam penggunaan loadbalancing tidak seperti rumus matematika 512 + 256 = 768, akan tetapi 512 + 256 = 512 + 256, atau 512 + 256 = 256 + 256 + 256.

Pada artikel ini kami menggunakan RB433UAH dengan kondisi sebagai berikut :
1.    Ether1 dan Ether2 terhubung pada ISP yang berbeda dengan besar bandwdith yang berbeda. ISP1 sebesar 512kbps dan ISP2 sebesar 256kbps.
2.    Kita akan menggunakan web-proxy internal dan menggunakan openDNS.
3.    Mikrotik RouterOS anda menggunakan versi 4.5  karena fitur PCC mulai dikenal pada versi 3.24.

Jika pada kondisi diatas berbeda dengan kondisi jaringan ditempat anda, maka konfigurasi yang akan kita jabarkan disini harus anda sesuaikan dengan konfigurasi untuk jaringan ditempat anda.

Konfigurasi Dasar

Berikut ini adalah Topologi Jaringan dan IP address yang akan kita gunakan
/ip address
add address=192.168.101.2/30 interface=ether1
add address=192.168.102.2/30 interface=ether2
add address=10.10.10.1/24 interface=wlan2
/ip dns
set allow-remote-requests=yes primary-dns=208.67.222.222 secondary-dns=208.67.220.220


Untuk koneksi client, kita menggunakan koneksi wireless pada wlan2 dengan range IP client 10.10.10.2 s/d 10.10.10.254 netmask 255.255.255.0, dimana IP 10.10.10.1 yang dipasangkan pada wlan2 berfungsi sebagai gateway dan dns server dari client. Jika anda menggunakan DNS dari salah satu isp anda, maka akan ada tambahan mangle yang akan kami berikan tanda tebal

Setelah pengkonfigurasian IP dan DNS sudah benar, kita harus memasangkan default route ke masing-masing IP gateway ISP kita agar router meneruskan semua trafik yang tidak terhubung padanya ke gateway tersebut. Disini kita menggunakan fitur check-gateway berguna jika salah satu gateway kita putus, maka koneksi akan dibelokkan ke gateway lainnya.
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.101.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.102.1 distance=2 check-gateway=ping


Untuk pengaturan Access Point sehingga PC client dapat terhubung dengan wireless kita, kita menggunakan perintah
/interface wireless
set wlan2 mode=ap-bridge band=2.4ghz-b/g ssid=Mikrotik disabled=no


Agar pc client dapat melakukan koneksi ke internet, kita juga harus merubah IP privat client ke IP publik yang ada di interface publik kita yaitu ether1 dan ether2.
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2


Sampai langkah ini, router dan pc client sudah dapat melakukan koneksi internet. Lakukan ping baik dari router ataupun pc client ke internet. Jika belum berhasil, cek sekali lagi konfigurasi anda.

Webproxy Internal
Pada routerboard tertentu, seperti RB450G, RB433AH, RB433UAH, RB800 dan RB1100 mempunyai expansion slot (USB, MicroSD, CompactFlash) untuk storage tambahan. Pada contoh berikut, kita akan menggunakan usb flashdisk yang dipasangkan pada slot USB. Untuk pertama kali pemasangan, storage tambahan ini akan terbaca statusnya invalid di /system store. Agar dapat digunakan sebagai media penyimpan cache, maka storage harus diformat dahulu dan diaktifkan Nantinya kita tinggal mengaktifkan webproxy dan set cache-on-disk=yes untuk menggunakan media storage kita. Jangan lupa untuk membelokkan trafik HTTP (tcp port 80) kedalam webproxy kita.

/store disk format-drive usb1
/store
add disk=usb1 name=cache-usb type=web-proxy
activate cache-usb

/ip proxy
set cache-on-disk=yes enabled=yes max-cache-size=200000KiB port=8080

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 in-interface=wlan2 action=redirect to-ports=8080



Pengaturan Mangle
Pada loadbalancing kali ini kita akan menggunakan fitur yang disebut PCC (Per Connection Classifier). Dengan PCC kita bisa mengelompokan trafik koneksi yang melalui atau keluar masuk router menjadi beberapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan atau dst-port. Router akan mengingat-ingat jalur gateway yang dilewati diawal trafik koneksi, sehingga pada paket-paket selanjutnya yang masih berkaitan dengan koneksi awalnya akan dilewatkan  pada jalur gateway yang sama juga. Kelebihan dari PCC ini yang menjawab banyaknya keluhan sering putusnya koneksi pada teknik loadbalancing lainnya sebelum adanya PCC karena perpindahan gateway.

Sebelum membuat mangle loadbalance, untuk mencegah terjadinya loop routing pada trafik, maka semua trafik client yang menuju network yang terhubung langsung dengan router, harus kita bypass dari loadbalancing. Kita bisa membuat daftar IP yang masih dalam satu network router dan  memasang mangle pertama kali sebagai berikut

/ip firewall address-list
add address=192.168.101.0/30 list=lokal
add address=192.168.102.0/30 list=lokal
add address=10.10.10.0/24 list=lokal

/ip firewall mangle
add action=accept chain=prerouting dst-address-list=lokal in-interface=wlan2 comment=”trafik lokal”
add action=accept chain=output dst-address-list=lokal


Pada kasus tertentu, trafik pertama bisa berasal dari Internet, seperti penggunaan remote winbox atau telnet dari internet dan sebagainya, oleh karena itu kita juga memerlukan mark-connection untuk menandai trafik tersebut agar trafik baliknya juga bisa melewati interface dimana trafik itu masuk
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=con-from-isp1 passthrough=yes comment=”trafik dari isp1”
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=con-from-isp2 passthrough=yes comment=”trafik dari isp2”


Umumnya, sebuah ISP akan membatasi akses DNS servernya dari IP yang hanya dikenalnya, jadi jika anda menggunakan DNS dari salah satu ISP anda, anda harus menambahkan mangle agar trafik DNS tersebut melalui gateway ISP yang bersangkutan bukan melalui gateway ISP lainnya. Disini kami berikan mangle DNS ISP1 yang melalui gateway ISP1. Jika anda menggunakan publik DNS independent, seperti opendns, anda tidak memerlukan mangle dibawah ini.
/ip firewall mangle
add action=mark-connection chain=output comment=dns dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=tcp comment=”trafik DNS citra.net.id”
add action=mark-connection chain=output dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=udp
add action=mark-routing chain=output connection-mark=dns new-routing-mark=route-to-isp1 passthrough=no


Karena kita menggunakan webproxy pada router, maka trafik yang perlu kita loadbalance ada 2 jenis. Yang pertama adalah trafik dari client menuju internet (non HTTP), dan trafik dari webproxy menuju internet. Agar lebih terstruktur dan mudah dalam pembacaannya, kita akan menggunakan custom-chain sebagai berikut :
/ip firewall mangle
add action=jump chain=prerouting comment=”lompat ke client-lb” connection-mark=no-mark in-interface=wlan2 jump-target=client-lb
add action=jump chain=output comment=”lompat ke lb-proxy” connection-mark=no-mark out-interface=!wlan2 jump-target=lb-proxy


Pada mangle diatas, untuk trafik loadbalance client pastikan parameter in-interface adalah interface yang terhubung dengan client, dan untuk trafik loadbalance webproxy, kita menggunakan chain output dengan parameter out-interface yang bukan terhubung ke interface client. Setelah custom chain untuk loadbalancing dibuat, kita bisa membuat mangle di custom chain tersebut sebagai berikut
/ip firewall mangle
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal loadbalancing klien”
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=client-lb comment=”akhir dari loadbalancing”

/ip firewall mangle
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal load balancing proxy”
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=lb-proxy comment=”akhir dari loadbalancing”


Untuk contoh diatas, pada loadbalancing client dan webproxy menggunakan parameter pemisahan trafik pcc yang sama, yaitu both-address, sehingga router akan mengingat-ingat berdasarkan src-address dan dst-address dari sebuah koneksi. Karena trafik ISP kita yang berbeda (512kbps dan 256kbps), kita membagi beban trafiknya menjadi 3 bagian. 2 bagian pertama akan melewati gateway ISP1, dan 1 bagian terakhir akan melewati gateway ISP2. Jika masing-masing trafik dari client dan proxy sudah ditandai, langkah berikutnya kita tinggal membuat mangle mark-route yang akan digunakan dalam proses routing nantinya
/ip firewall mangle
add action=jump chain=prerouting comment=”marking route client” connection-mark=!no-mark in-interface=wlan2 jump-target=route-client
add action=mark-routing chain=route-client connection-mark=to-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=to-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=return chain=route-client disabled=no

/ip firewall mangle
add action=mark-routing chain=output comment=”marking route proxy” connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 out-interface=!wlan2 passthrough=no
add action=mark-routing chain=output connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 out-interface=!wlan2 passthrough=no



Pengaturan Routing
Pengaturan mangle diatas tidak akan berguna jika anda belum membuat routing berdasar mark-route yang sudah kita buat. Disini kita juga akan membuat routing backup, sehingga apabila sebuah gateway terputus, maka semua koneksi akan melewati gateway yang masing terhubung

/ip route
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp1 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp1 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp2 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp2 distance=2
Pengujian
Dari hasil pengujian kami, didapatkan sebagai berikut
Dari gambar terlihat, bahwa hanya dengan melakukan 1 file download (1 koneksi), kita hanya mendapatkan speed 56kBps (448kbps) karena pada saat itu melewati gateway ISP1, sedangkan jika kita mendownload file (membuka koneksi baru) lagi pada web lain, akan mendapatkan 30kBps (240kbps). Dari pengujian ini terlihat dapat disimpulkan bahwa
512kbps + 256kbps ≠ 768kbps

Catatan :
* Loadbalancing menggunakan teknik pcc ini akan berjalan efektif dan mendekati seimbang jika semakin banyak koneksi (dari client) yang terjadi.
* Gunakan ISP yang memiliki bandwith FIX bukan Share untuk mendapatkan hasil yang lebih optimal.
* Load Balance menggunakan PCC ini bukan selamanya dan sepenuhnya sebuah solusi yang pasti berhasil baik di semua jenis network, karena proses penyeimbangan dari traffic adalah berdasarkan logika probabilitas.
  
Demikianlah Tutorial Cara Setting Load Balancing Mikrotik menggunakan Metode PPC yang diambil dari web Mikrotik.co.id. Selamat mencoba dan Semoga bermanfaat :)

Sumber :
Share:

Cara Setting Load Balancing Mikrotik Metode PPC

Load Balance / Load Balancing Mikrotik adalah sebuah teknik atau metode untuk membagi beban ke dalam beberapa jalur (link) sehingga penggunaan jalur (link) menjadi lebih baik. Load balance Mikrotik Sebelumnya sudah pernah saya bahas pada artikel ini Load Balance / Load Balancing Mikrotik.


Selanjutnya pada artikel ini akan saya bahas tentang cara setting load balance mikrotik meggunakan metode PPC. Karena keterbatasan waktu dan peralatan, Tutorial Load Balance Mikrotik kali ini saya ambil dari web mikrotik.co.id sebagai berikut :

Selama ini banyak dari kita yang beranggapan salah, bahwa dengan menggunakan loadbalance dua jalur koneksi , maka besar bandwidth yang akan kita dapatkan menjadi dua kali lipat dari bandwidth sebelum menggunakan loadbalance (akumulasi dari kedua bandwidth tersebut). Hal ini perlu kita perjelas dahulu, bahwa loadbalance tidak akan menambah besar bandwidth yang kita peroleh, tetapi hanya bertugas untuk membagi trafik dari kedua bandwidth tersebut agar dapat terpakai secara seimbang.

Dengan artikel ini, kita akan membuktikan bahwa dalam penggunaan loadbalancing tidak seperti rumus matematika 512 + 256 = 768, akan tetapi 512 + 256 = 512 + 256, atau 512 + 256 = 256 + 256 + 256.

Pada artikel ini kami menggunakan RB433UAH dengan kondisi sebagai berikut :
1.    Ether1 dan Ether2 terhubung pada ISP yang berbeda dengan besar bandwdith yang berbeda. ISP1 sebesar 512kbps dan ISP2 sebesar 256kbps.
2.    Kita akan menggunakan web-proxy internal dan menggunakan openDNS.
3.    Mikrotik RouterOS anda menggunakan versi 4.5  karena fitur PCC mulai dikenal pada versi 3.24.

Jika pada kondisi diatas berbeda dengan kondisi jaringan ditempat anda, maka konfigurasi yang akan kita jabarkan disini harus anda sesuaikan dengan konfigurasi untuk jaringan ditempat anda.

Konfigurasi Dasar

Berikut ini adalah Topologi Jaringan dan IP address yang akan kita gunakan
/ip address
add address=192.168.101.2/30 interface=ether1
add address=192.168.102.2/30 interface=ether2
add address=10.10.10.1/24 interface=wlan2
/ip dns
set allow-remote-requests=yes primary-dns=208.67.222.222 secondary-dns=208.67.220.220


Untuk koneksi client, kita menggunakan koneksi wireless pada wlan2 dengan range IP client 10.10.10.2 s/d 10.10.10.254 netmask 255.255.255.0, dimana IP 10.10.10.1 yang dipasangkan pada wlan2 berfungsi sebagai gateway dan dns server dari client. Jika anda menggunakan DNS dari salah satu isp anda, maka akan ada tambahan mangle yang akan kami berikan tanda tebal

Setelah pengkonfigurasian IP dan DNS sudah benar, kita harus memasangkan default route ke masing-masing IP gateway ISP kita agar router meneruskan semua trafik yang tidak terhubung padanya ke gateway tersebut. Disini kita menggunakan fitur check-gateway berguna jika salah satu gateway kita putus, maka koneksi akan dibelokkan ke gateway lainnya.
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.101.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.102.1 distance=2 check-gateway=ping


Untuk pengaturan Access Point sehingga PC client dapat terhubung dengan wireless kita, kita menggunakan perintah
/interface wireless
set wlan2 mode=ap-bridge band=2.4ghz-b/g ssid=Mikrotik disabled=no


Agar pc client dapat melakukan koneksi ke internet, kita juga harus merubah IP privat client ke IP publik yang ada di interface publik kita yaitu ether1 dan ether2.
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2


Sampai langkah ini, router dan pc client sudah dapat melakukan koneksi internet. Lakukan ping baik dari router ataupun pc client ke internet. Jika belum berhasil, cek sekali lagi konfigurasi anda.

Webproxy Internal
Pada routerboard tertentu, seperti RB450G, RB433AH, RB433UAH, RB800 dan RB1100 mempunyai expansion slot (USB, MicroSD, CompactFlash) untuk storage tambahan. Pada contoh berikut, kita akan menggunakan usb flashdisk yang dipasangkan pada slot USB. Untuk pertama kali pemasangan, storage tambahan ini akan terbaca statusnya invalid di /system store. Agar dapat digunakan sebagai media penyimpan cache, maka storage harus diformat dahulu dan diaktifkan Nantinya kita tinggal mengaktifkan webproxy dan set cache-on-disk=yes untuk menggunakan media storage kita. Jangan lupa untuk membelokkan trafik HTTP (tcp port 80) kedalam webproxy kita.

/store disk format-drive usb1
/store
add disk=usb1 name=cache-usb type=web-proxy
activate cache-usb

/ip proxy
set cache-on-disk=yes enabled=yes max-cache-size=200000KiB port=8080

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 in-interface=wlan2 action=redirect to-ports=8080



Pengaturan Mangle
Pada loadbalancing kali ini kita akan menggunakan fitur yang disebut PCC (Per Connection Classifier). Dengan PCC kita bisa mengelompokan trafik koneksi yang melalui atau keluar masuk router menjadi beberapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan atau dst-port. Router akan mengingat-ingat jalur gateway yang dilewati diawal trafik koneksi, sehingga pada paket-paket selanjutnya yang masih berkaitan dengan koneksi awalnya akan dilewatkan  pada jalur gateway yang sama juga. Kelebihan dari PCC ini yang menjawab banyaknya keluhan sering putusnya koneksi pada teknik loadbalancing lainnya sebelum adanya PCC karena perpindahan gateway.

Sebelum membuat mangle loadbalance, untuk mencegah terjadinya loop routing pada trafik, maka semua trafik client yang menuju network yang terhubung langsung dengan router, harus kita bypass dari loadbalancing. Kita bisa membuat daftar IP yang masih dalam satu network router dan  memasang mangle pertama kali sebagai berikut

/ip firewall address-list
add address=192.168.101.0/30 list=lokal
add address=192.168.102.0/30 list=lokal
add address=10.10.10.0/24 list=lokal

/ip firewall mangle
add action=accept chain=prerouting dst-address-list=lokal in-interface=wlan2 comment=”trafik lokal”
add action=accept chain=output dst-address-list=lokal


Pada kasus tertentu, trafik pertama bisa berasal dari Internet, seperti penggunaan remote winbox atau telnet dari internet dan sebagainya, oleh karena itu kita juga memerlukan mark-connection untuk menandai trafik tersebut agar trafik baliknya juga bisa melewati interface dimana trafik itu masuk
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=con-from-isp1 passthrough=yes comment=”trafik dari isp1”
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=con-from-isp2 passthrough=yes comment=”trafik dari isp2”


Umumnya, sebuah ISP akan membatasi akses DNS servernya dari IP yang hanya dikenalnya, jadi jika anda menggunakan DNS dari salah satu ISP anda, anda harus menambahkan mangle agar trafik DNS tersebut melalui gateway ISP yang bersangkutan bukan melalui gateway ISP lainnya. Disini kami berikan mangle DNS ISP1 yang melalui gateway ISP1. Jika anda menggunakan publik DNS independent, seperti opendns, anda tidak memerlukan mangle dibawah ini.
/ip firewall mangle
add action=mark-connection chain=output comment=dns dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=tcp comment=”trafik DNS citra.net.id”
add action=mark-connection chain=output dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=udp
add action=mark-routing chain=output connection-mark=dns new-routing-mark=route-to-isp1 passthrough=no


Karena kita menggunakan webproxy pada router, maka trafik yang perlu kita loadbalance ada 2 jenis. Yang pertama adalah trafik dari client menuju internet (non HTTP), dan trafik dari webproxy menuju internet. Agar lebih terstruktur dan mudah dalam pembacaannya, kita akan menggunakan custom-chain sebagai berikut :
/ip firewall mangle
add action=jump chain=prerouting comment=”lompat ke client-lb” connection-mark=no-mark in-interface=wlan2 jump-target=client-lb
add action=jump chain=output comment=”lompat ke lb-proxy” connection-mark=no-mark out-interface=!wlan2 jump-target=lb-proxy


Pada mangle diatas, untuk trafik loadbalance client pastikan parameter in-interface adalah interface yang terhubung dengan client, dan untuk trafik loadbalance webproxy, kita menggunakan chain output dengan parameter out-interface yang bukan terhubung ke interface client. Setelah custom chain untuk loadbalancing dibuat, kita bisa membuat mangle di custom chain tersebut sebagai berikut
/ip firewall mangle
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal loadbalancing klien”
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=client-lb comment=”akhir dari loadbalancing”

/ip firewall mangle
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal load balancing proxy”
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=lb-proxy comment=”akhir dari loadbalancing”


Untuk contoh diatas, pada loadbalancing client dan webproxy menggunakan parameter pemisahan trafik pcc yang sama, yaitu both-address, sehingga router akan mengingat-ingat berdasarkan src-address dan dst-address dari sebuah koneksi. Karena trafik ISP kita yang berbeda (512kbps dan 256kbps), kita membagi beban trafiknya menjadi 3 bagian. 2 bagian pertama akan melewati gateway ISP1, dan 1 bagian terakhir akan melewati gateway ISP2. Jika masing-masing trafik dari client dan proxy sudah ditandai, langkah berikutnya kita tinggal membuat mangle mark-route yang akan digunakan dalam proses routing nantinya
/ip firewall mangle
add action=jump chain=prerouting comment=”marking route client” connection-mark=!no-mark in-interface=wlan2 jump-target=route-client
add action=mark-routing chain=route-client connection-mark=to-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=to-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=return chain=route-client disabled=no

/ip firewall mangle
add action=mark-routing chain=output comment=”marking route proxy” connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 out-interface=!wlan2 passthrough=no
add action=mark-routing chain=output connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 out-interface=!wlan2 passthrough=no



Pengaturan Routing
Pengaturan mangle diatas tidak akan berguna jika anda belum membuat routing berdasar mark-route yang sudah kita buat. Disini kita juga akan membuat routing backup, sehingga apabila sebuah gateway terputus, maka semua koneksi akan melewati gateway yang masing terhubung

/ip route
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp1 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp1 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp2 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp2 distance=2
Pengujian
Dari hasil pengujian kami, didapatkan sebagai berikut
Dari gambar terlihat, bahwa hanya dengan melakukan 1 file download (1 koneksi), kita hanya mendapatkan speed 56kBps (448kbps) karena pada saat itu melewati gateway ISP1, sedangkan jika kita mendownload file (membuka koneksi baru) lagi pada web lain, akan mendapatkan 30kBps (240kbps). Dari pengujian ini terlihat dapat disimpulkan bahwa
512kbps + 256kbps ≠ 768kbps

Catatan :
* Loadbalancing menggunakan teknik pcc ini akan berjalan efektif dan mendekati seimbang jika semakin banyak koneksi (dari client) yang terjadi.
* Gunakan ISP yang memiliki bandwith FIX bukan Share untuk mendapatkan hasil yang lebih optimal.
* Load Balance menggunakan PCC ini bukan selamanya dan sepenuhnya sebuah solusi yang pasti berhasil baik di semua jenis network, karena proses penyeimbangan dari traffic adalah berdasarkan logika probabilitas.
  
Demikianlah Tutorial Cara Setting Load Balancing Mikrotik menggunakan Metode PPC yang diambil dari web Mikrotik.co.id. Selamat mencoba dan Semoga bermanfaat :)

Sumber :
Share:

Blog Archive